Guild Wars Forums - GW Guru
 
 

Go Back   Guild Wars Forums - GW Guru > Forest of True Sight > Technician's Corner > Software

Reply
 
Thread Tools Display Modes
Old Mar 05, 2011, 04:22 PM // 16:22   #1
Turk The Legendary
Wilds Pathfinder
 
Turk The Legendary's Avatar
 
Join Date: Sep 2009
Location: Fissure of Woe
Guild: Club of A Thousand Pandas [LOD大]
Profession: W/
Advertisement

Disable Ads
Default GW Cannot write file to directory

closed...................

Last edited by Turk The Legendary; May 06, 2011 at 08:06 PM // 20:06..
Turk The Legendary is offline   Reply With Quote
Old Mar 06, 2011, 09:46 PM // 21:46   #2
Turk The Legendary
Wilds Pathfinder
 
Turk The Legendary's Avatar
 
Join Date: Sep 2009
Location: Fissure of Woe
Guild: Club of A Thousand Pandas [LOD大]
Profession: W/
Default

To the top....
Turk The Legendary is offline   Reply With Quote
Old Mar 06, 2011, 10:19 PM // 22:19   #3
Spiritz
Forge Runner
 
Join Date: Apr 2007
Guild: DMFC
Default

I had this and way i fixed it was to run gw.exe as admin option and wham it worked since
Spiritz is offline   Reply With Quote
Old Mar 06, 2011, 10:23 PM // 22:23   #4
Kunder
Desert Nomad
 
Join Date: Nov 2010
Default

Installing anything to the C: drive, in particular Windows-protected folders like program files, is a bad idea.
Kunder is offline   Reply With Quote
Old Mar 07, 2011, 03:26 AM // 03:26   #5
Allienne
Ascalonian Squire
 
Join Date: Sep 2009
Guild: AWAR
Profession: E/Mo
Default

It could be a virus causing it or perhaps a firewall. They can be tricky. Try running an antivirus or if you don't have one try install Avast Antivirus it works and it's free. Cheers!
Allienne is offline   Reply With Quote
Old Mar 07, 2011, 04:48 PM // 16:48   #6
Quaker
Hell's Protector
 
Quaker's Avatar
 
Join Date: Aug 2005
Location: Canada
Guild: Brothers Disgruntled
Default

Just as a random thought - Windows 7 attempts to put Templates, etc. into a folder in "Documents" - make sure there's no permissions problems with the Documents folder.
Quaker is offline   Reply With Quote
Old Mar 07, 2011, 06:51 PM // 18:51   #7
forever
Frost Gate Guardian
 
Join Date: Jun 2005
Default

I had the same problem with Vista x64, running as administrator solved the problem. No idea why it didn't work for you.
forever is offline   Reply With Quote
Old Mar 10, 2011, 02:06 AM // 02:06   #8
Turk The Legendary
Wilds Pathfinder
 
Turk The Legendary's Avatar
 
Join Date: Sep 2009
Location: Fissure of Woe
Guild: Club of A Thousand Pandas [LOD大]
Profession: W/
Default

bump...........
Turk The Legendary is offline   Reply With Quote
Old Mar 10, 2011, 03:08 PM // 15:08   #9
Snograt
rattus rattus
 
Snograt's Avatar
 
Join Date: Jan 2006
Location: London, UK GMT±0 ±1hr DST
Guild: [GURU]GW [wiki]GW2
Profession: R/
Default

No comment on the previous observations/tips?

Make a new folder on root - let's say C:\Guild Wars - install GW in that and see how you get on.
Snograt is offline   Reply With Quote
Old Mar 10, 2011, 06:50 PM // 18:50   #10
SH4D0WZ0MB1E
Ascalonian Squire
 
SH4D0WZ0MB1E's Avatar
 
Join Date: Sep 2009
Default

Don't know what Antivirus/Firewall you are running, but I ran into this with Comodo a few days ago. It kept blocking gw.tmp from running, and it wouldn't give me any error messages. I know you said you quit your antivirus/firewall, but just FYI that is a bad idea to do in the first place. What's the point of having them if you are disabling them when going online?

If you are running Comodo then bring up the security center thing and in your firewall section look for blocked programs, find gw.tmp, put a checkmark in the box and then select move to trusted files.

I'm guessing you had no luck with the "run as admin" suggestion? Though with the unable to write option, it does seem like a permissoin issue. Windows 7 likes to really try and lock down your computer...
SH4D0WZ0MB1E is offline   Reply With Quote
Old Mar 12, 2011, 04:14 AM // 04:14   #11
Turk The Legendary
Wilds Pathfinder
 
Turk The Legendary's Avatar
 
Join Date: Sep 2009
Location: Fissure of Woe
Guild: Club of A Thousand Pandas [LOD大]
Profession: W/
Default

Quote:
Originally Posted by Snograt View Post
No comment on the previous observations/tips?

Make a new folder on root - let's say C:\Guild Wars - install GW in that and see how you get on.
Didn't comment on most of the observations because most of them were addressed in my original post and i feel people just like to get that post counter up another number. Almost every comment here was already addressed in my original post. Nothing worked, but no surprise there. Bump...
Turk The Legendary is offline   Reply With Quote
Old Mar 12, 2011, 12:06 PM // 12:06   #12
Snograt
rattus rattus
 
Snograt's Avatar
 
Join Date: Jan 2006
Location: London, UK GMT±0 ±1hr DST
Guild: [GURU]GW [wiki]GW2
Profession: R/
Default

Well, have you tried my suggestion? The error you're getting is one that is often seen with permission problems. Yes, I know you've checked administrative access and individual folder permissions, but this is Windows 7 we're talking about. It hates you installing program files in the Program Files or Program Files (x86) directories. Sometimes.

I'm serious - give it a shot.
Snograt is offline   Reply With Quote
Old Mar 13, 2011, 09:16 PM // 21:16   #13
Turk The Legendary
Wilds Pathfinder
 
Turk The Legendary's Avatar
 
Join Date: Sep 2009
Location: Fissure of Woe
Guild: Club of A Thousand Pandas [LOD大]
Profession: W/
Default

Quote:
Originally Posted by Snograt View Post
Well, have you tried my suggestion? The error you're getting is one that is often seen with permission problems. Yes, I know you've checked administrative access and individual folder permissions, but this is Windows 7 we're talking about. It hates you installing program files in the Program Files or Program Files (x86) directories. Sometimes.

I'm serious - give it a shot.
Quote:
Originally Posted by Turk The Legendary View Post
I have installed it in 3 other folders than the C drive including my desktop so thats not the issue either.
That was in my post also. I've pretty much given up on fixing it, nobody here really knows how to fix it either. Still open to suggestions but please read my post before commenting as most of the current suggestions were already addressed in it.
Turk The Legendary is offline   Reply With Quote
Old Mar 24, 2011, 01:56 AM // 01:56   #14
Denim
Ascalonian Squire
 
Join Date: Feb 2011
Default

"..I have tried unlocking the folders and re-applying administrative commands.." Ok. Since the GW folders & executable have proper permissions assigned (no warnings displayed), some program is undoing your work. Run as Administrator IS necessary, for the shortcut & gw.exe, imo. Any utilities or security programs running..which may be protecting access to that folder?
Denim is offline   Reply With Quote
Old May 06, 2011, 12:41 PM // 12:41   #15
some-_1
Lion's Arch Merchant
 
some-_1's Avatar
 
Join Date: Jan 2008
Location: Reading, England
Guild: Zaishen Masters [ZM]
Profession: R/
Default

Is your user account an administrator? If Guild Wars is set to run as administrator then there is no reason why it can't write to /Program Files/ as long as your account is also an Administrator.

Other than that, try installing it to your Documents area as you will have full control to that folder, add it to Anti-Virus exceptions, check to make sure you're not running it with any switches etc.

You also mentioned you checked the Folder permissions, have you tried checking the individual file permissions (mainly on the gw.dat file) to make sure those are set to, at the very least, "Read & Write" and "Modify"? (IMO "Full Control" is the best option for GWs).
some-_1 is offline   Reply With Quote
Old May 06, 2011, 08:06 PM // 20:06   #16
Turk The Legendary
Wilds Pathfinder
 
Turk The Legendary's Avatar
 
Join Date: Sep 2009
Location: Fissure of Woe
Guild: Club of A Thousand Pandas [LOD大]
Profession: W/
Default

I fixed this a long time ago, Close please
Turk The Legendary is offline   Reply With Quote
Old May 06, 2011, 09:53 PM // 21:53   #17
Quaker
Hell's Protector
 
Quaker's Avatar
 
Join Date: Aug 2005
Location: Canada
Guild: Brothers Disgruntled
Default

Quote:
Originally Posted by Turk The Legendary View Post
I fixed this a long time ago, Close please
Well, thanks for telling us how you fixed it.... er.... or not.
Quaker is offline   Reply With Quote
Reply

Share This Forum!  
 
 
           

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:08 PM // 23:08.


Vote on the Guild Wars Top 200
Guild Wars Top 200 - Cheats Free Guides, Downloads, Fansites. The Gold standard

Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.